How to perform hot backup Permanent link e1 addition Dialer ADSL with bgp

Facebookgoogle_plus

Bgp routing is more powerful than dial-up ADSL
Because distanse lower. The dialer was active but did not get through traffic
Metric was also higher Permanent link

track 1 interface fastethernet 0/0  ip routing
track 2 interface dialel1  ip routing

interface fastethernet  0/0
connection to E1
IP ADDRESS 214.99.7.9 244  255.255.255.252
 
inetface fastethernet 0/1
connection to dialer
pppoe enable
pppoe-clinet diler -pool number 1

interface vlan 1
connction to lan
ip address 210.100.8.1   255.255.255.240

dialer 1
ip address negotiated
encapsulation ppp
dialer pool 1
ppp paa sent -username    password

bgp

router bgp 4800 ? number local 
 neighbor 214.99.7.9 245 peer-group test   ?ip  of isp
neighbor test remote-as 500  ?number of isp

neighbor test route-map name  backup   in
neighbor test route-map client out
neighbor 214.99.7.9 245  activate   

no synchronizatio
 bgp log-neighbor-changes
 redistribute connected
 no auto-summary
redistribute connected
network 210.100.8.0   255.255.255.240 

ip prefix-list client-test seq 10 permit 210.100.8.0/28
route map backup permit 20
match ip address backup
route map client permit 20
match ip address prefix-list  client-test
ip access-list standard client
permit 0.0.0.0 

ip route 0.0.0.0 0.0.0.0 fastethernet 0/0
track 1
ip route 0.0.0.0 0.0.0.0  dialer 1 300 track 2