ip dhcp pool LAN
   network 84.94.216.0 255.255.255.240
   default-router 84.94.216.1
   dns-server 
!
ip dhcp pool VLAN20
   network 172.16.0.0 255.255.255.0
   default-router 172.16.0.1
   dns-server
!
ip dhcp pool VLAN10
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
   dns-server 
!
ip dhcp pool VLAN30
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 
        
ip cef

interface FastEthernet0
   description "Connection to modem  "
!
interface FastEthernet1
!        
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 no ip address
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet4.1
 encapsulation dot1Q 1 native
 ip address 70.66.5.99 255.255.255.240
!
interface FastEthernet4.10
 encapsulation dot1Q 5
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet4.20
 encapsulation dot1Q 6
 ip address 172.16.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet4.
 description USERS
 encapsulation dot1Q 7
 ip address 10.0.0.1 255.0.0.0
 ip nat inside
 ip virtual-reassembly

!
interface Vlan1
 no ip address
 pppoe enable group global
 pppoe-client dial-pool-number 1
!        
interface Dialer0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 ppp pap sent-username xxxx password xxxx
!        
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!        
!        
ip nat inside source list 10 interface Dialer0 overload
ip nat inside source list 20 interface Dialer0 overload
ip nat inside source list 30 interface Dialer0 overload
!        
access-list 10 permit 10.0.0.0 0.255.255.255
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 20 permit 172.16.0.0 0.0.0.255