how to config gre tunnel cisco two cable cbl

Facebookgoogle_plus

interface Tunnel1
 description "GRE Tunnel to isp"
 ip address 70.66.5.9 255.255.255.252
 tunnel source FastEthernet4
  description ip of cable cbl tunnel destination 70.66.5.2 255.255.255.224
 tunnel mode ipip
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 description "Connection to Cable Modem"
 ip address dhcp client-id FastEthernet4
 load-interval 30
 duplex auto
 speed auto
 no cdp enable
!
interface Vlan1
 description "Connection to LAN"
 ip address 192.168.1.1 255.255.255.0
 load-interval 30
 hold-queue 32 in
!
ip classless
ip route 0.0.0.0 0.0.0.0 Tunnel1 70.66.5.10
  descriotion connection to cable cbl ip route 70.66.5.2 255.255.255.255 FastEthernet4 dhcp