How to config GRE tunnel Between cisco router

Facebookgoogle_plus

interface Tunnel1
 
 10.0.0.1 ip address   
tunnel source FastEthernet0/1
tunnel destination 70.66.5.10 255.255.255.240

description connected to lan " interface fastethernet 0/0    
ip address 172.16.1.1 255.255.0.0
ip nat inside

  tunnel source FastEthernet0/1 
 description connected to wan "ip adrress 60.66.5.9 255.255.255.240

ip route 0.0.0.0 0.0.0.0  FastEthernet0/1 60.66.5.10
ip route  172.16.2.0 255.255.0.0 10.0.0.2

router B —————————————

interface Tunnel1
 
 10.0.0.2 ip address   
tunnel source FastEthernet0/1
tunnel destination 60.66.5.9 255.255.255.240  

description connected to lan " interface fastethernet 0/0    
ip address 172.16.1.1 255.255.0.0
ip nat inside

  tunnel source FastEthernet0/1 
 description connected to wan "ip adrress 70.66.5.10 255.255.255.240

ip route 0.0.0.0 0.0.0.0  FastEthernet0/1 70.66.5.11
ip route  172.16.2.0 255.255.0.0 10.0.0.1