how to config adsl cisco 800

Facebookgoogle_plus

(The main DNS server)

ip name-server
ip name-server

interface ATM0
   (Setting the vp / vc for ADSL )  
pvc 8/48
     (The link to the dialer atm )
 pppoe-client dial-pool-number 1           
 
Ip dhcp pool
lan
  Network 192.168.0.0 255.255.255.0
  Dns-server
  Default-router 192.168.0.1
  Lease 0 0 1

(Set IP address of your internal network)
interface Vlan1
ip address 192.168.0.1 255.255.255.0
(Will allow the network to work with Nate)
ip nat inside     –

interface Dialer0
 ip address negotiated
(enable the dialer to work with nat  – the IP
interface will be the one that on this
(is used for all the computers in the ethernet                  
ip nat outside               
 encapsulation ppp       
 

   (The dialer link to atm)     
dialer pool 1           
 
(Setting up dial-up username and password to isp )
  
ppp pap sent-username  xxxxxxx password xxxxx

ip route 0.0.0.0 0.0.0.0 Dialer0

access-list 1 permit 192.168.10.0 0.0.0.255

   (192.168.10.0 0.0.0.255 permits only addresses from the subnet
    (Used in this case for the NAT

 (permit  all addresses in access-list 1   ,
 ( and to use the Dialer1 interface for NAT
ip nat inside source list 1 interface Dialer0 overload