interface FastEthernet0/0

 description "Connection to ADSL modem"

 no ip address

 load-interval 30

 duplex auto

 speed auto

 pppoe enable

 pppoe-client dial-pool-number 1

!

interface FastEthernet0/1

 description "Connection to ADSL modem"

 no ip address

 duplex auto

 speed auto

 pppoe enable

 pppoe-client dial-pool-number 2

interface FastEthernet0/0/0

interface FastEthernet0/0/1

interface FastEthernet0/0/2
     
interface FastEthernet0/0/3

interface Vlan1

 description "Connection to LAN"

 ip address 70.66.5.1 255.255.255.0

 ip policy route-map traffic

interface Dialer0

 ip address negotiated

 encapsulation ppp

 dialer pool 1

 peer default ip address 1.1.1.1

 ppp pap sent-username xxxxx password xxxxx

interface Dialer1

ip address negotiated

 encapsulation ppp

 load-interval 30

 dialer pool 2

 peer default ip address 2.2.2.2

 ppp pap sent-username xxxxx password xxxx

ip classless

ip route 0.0.0.0 0.0.0.0 2.2.2.2

ip route 0.0.0.0 0.0.0.0 1.1.1.1

ip access-list extended dialer0
permit ip 70.66.5.0   0.0.0.7 any
permit ip 70.66.5.8   0.0.0.7 any
permit ip 70.66.5.24   0.0.0.7 any

ip access-list extended dialer1
permit ip 70.66.5.0   0.0.0.7 any
permit ip 70.66.5.16   0.0.0.7 any
permit ip 70.66.5.32   0.0.0.7 any
 

route-map traffic permit 10

 match ip address dialer0

 set ip next-hop 1.1.1.1

!

route-map traffic permit 20

 match ip address dialer1

 set ip next-hop 2.2.2.2